Commit 5a1f6189 authored by Robert's avatar Robert

Updated README

parent 2a5e8cd3
Pipeline #1467 failed with stage
in 1 minute and 29 seconds
......@@ -8,7 +8,7 @@ grouprise is a platform destined to encourage and enable social action and solid
You may want to install the latest [snapshot build](https://git.hack-hro.de/stadtgestalten/stadtgestalten/builds/artifacts/master/raw/build/debian/export/stadtgestalten.deb?job=deb-package) as a deb package. Please note that this is a rather dirty package (only amd64, containing a virtualenv with python3.5 - suitable for Debian stretch).
### For developers
1. You will need [yarn](https://yarnpkg.com/lang/en/), [virtualenv](https://virtualenv.pypa.io/en/stable/), [node](https://nodejs.org/en/), [python3](https://www.python.org/), [flake8](http://flake8.pycqa.org/en/latest/), [pip](https://pip.pypa.io/en/stable/) and [make](https://www.gnu.org/software/make/) to get started. If you have all of those, you may proceed :). Otherwise see the Dependencies Section
1. You will need [virtualenv](https://virtualenv.pypa.io/en/stable/), [node](https://nodejs.org/en/), [python3](https://www.python.org/), [pip](https://pip.pypa.io/en/stable/) and [make](https://www.gnu.org/software/make/) to get started. If you have all of those, you may proceed :). Otherwise see the Dependencies Section
2. Run `make app_setup` and wait until you see something like `Starting development server at http://127.0.0.1:8000/`
3. Visit http://127.0.0.1:8000/
......@@ -21,13 +21,12 @@ For `virtualenv`, `python3`, `flake8` and `pip` use apt:
```sh
apt install make virtualenv python3 python3-flake8 python3-pip
```
`node` is available as `nodejs` and `nodejs-legacy` (please install both), but you’ll have to have Debian Stretch to get a node version that is going to work. The nodejs people also offer pre-packaged up to date builds [here](https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions).
`yarn` is not yet available in Debian. Take a look at their [installation manual](https://yarnpkg.com/en/docs/install).
`node` is available as `nodejs`, but you’ll have to have Debian Stretch to get a node version that is going to work. The nodejs people also offer pre-packaged up to date builds [here](https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions).
### Arch Linux
Fortunately all of the required packages are available via pacman.
```sh
pacman -Sy make nodejs yarn flake8 python python-virtualenv python-pip
pacman -Sy make nodejs flake8 python python-virtualenv python-pip
```
......@@ -53,7 +52,7 @@ The command above requires the locale 'de_DE.UTF8' in the system of the database
## Production deployment
We recommend to use the provided debian package. It already comes with a UWSGI config.
We recommend to use the provided debian package. It already comes with a UWSGI config. See also [DEPLOYMENT.md](./docs/deployment/DEPLOYMENT.md).
## Contributing
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment